Home

Biostratigraphy
Geochronology

About StrataData

Staff & Associates

Contact

Blog

v2.1/v2.1.1 Updates

You will need an updated license to run v2.1/v2.1.1

Press this button to run the StrataBugs updater/installer:

If the button above does not work, or keeps going to the Java update page, then try clicking here to download the applet launch file. You may be able to run this file directly when downloaded, or "Open With..." the Java webstart launcher. This can be found in your java folder (C:\Program Files\Java\jre...\bin\javaws.exe)

 

Alternative installation method

Following changes to Oracle's Java licensing policy, you may not be able to run the embedded java runtime environment which is invoked in the ink above. The alternative is to install a standalone freely available java runtime environment first, then download the StrataBugs updater application to install or update StrataBugs. This method is described below.

Download java

If you are downloading java solely for use with StrataBugs, then create a top level "StrataBugs" folder, and download the JRE into it. Follow this link to download the correct version of java for your platform. For StrataBugs 2.1/2.1.1 you will need Java 8., For most Windows installations, you will need the 64-bit Windows JRE:

Download the JRE from Amazon

Extract the files from the .zip file into, for example, D:\StrataBugs ...

(If you have a ultra high resolution screen, then the updater will look very compressed. Contact StrataData for a workaround to this issue).

Download the StrataBugs updater

Now download a copy of the StrataBugs updater (SBupdate.jar), and save this file in the StrataBugs folder.

StrataBugs updater

Run the updater by double-clicking the file SBupdate.jar. If you get an "Open with..." prompt, then open it with the application java.exe which is in the Java\...\bin folder that you downloaded earlier.

When the updater opens, you should then be able to download the latest StrataBugs applications into a StrataBugs2-1 folder within your StrataBugs folder.

See this page for setting up the environment varaible.